RESTRICCIONES CON DANSGUARDIAN

Forums: 

Hola a todos, denme un ayuda
Actualmente tengo solo el squid con los acl que me controla el acceso a la navegacion, tengo en 2 archivos el uno es las ips y el otro es a las paginas que quiero que accesen las ips antes mencionadas, funciona perfecto sin ningun problema. Pero a la hora de levantar el servicio del danguardian no me funcionan los acl y todos pueden navegar VIVA LA FIESTA, como controlo esto con el dansguradian que ciertas ips puedan accesar a ciertas paginas.
utilizo Centos 5

Mira este

Mira este post:

http://www.ecualug.org/2008/07/29/forums/dansguardian_y_squid

Saludos,

----
Edwin Boza
about.me/edwinboza

ya hice estos cambios luego

ya hice estos cambios

luego en el squid.conf activar estas opciones
follow_x_forwarded_for allow localhost
acl_uses_indirect_client on
log_uses_indirect_client on

y en el dansguardian.conf

forwardedfor = on

Hasta lo hice todo bien pero me queda una duda que cuando bloqueo una pagina me sigue saliendo como que es el squid quien me esta controlando y no me sale la pantalla del danguardian.

Pero esta linea no la entiendo (esta line ano la hecho porque no la entiendo como la hago y en donde)
--enable-follow-x-forwarded-for \

pero disculpa la duda es que

pero disculpa la duda es que cuando el usuario quiere entrar a una pagina que no tiene permisos me sale URL denedago y creo que deberia salir la del dansgurdian de bloqueo es asi no no es asi

Prueba con squidGuard

Imagen de skypower

Te recomiendo que pruebes con squidGuard, es bastante sencillo...


# SQUIDGUARD
# -----------------------------------------------------------------------------
redirect_program /usr/bin/squidGuard -c /etc/squid/squidGuard.conf
redirect_children 10

Mira un ejemplo del squidguard...

dbhome /var/lib/squidguard/db
logdir /var/log/squid

dest good {
}

dest local {
}

dest porn {
domainlist porn/domains
urllist porn/urls
}

acl {
default {
pass !porn all
redirect http://tudominio/politicainternet.html
}
}


squidGuard -C all && chown -R proxy:proxy /var/lib/squidguard && killall squid && invoke-rc.d squid restart

Salud2s...

ecualug
______________________
!!!AdminRed_Debian!!!