Squid3: Autentificacion no satisfactoria...!!!

Imagen de arvic1978

Forums: 

:(
Hola amigos.
Ante todo, saludos.
He estado mirando en otros foros y no he encontrado respuesta al problema que les voy a plantear a continuacion.
Sucede que uso debian 4.0 etch y tengo recientemente instale squid3 como proxy. Siguiendo manuales y googleando un poco logre configurarlo a medias. El problema es que cuando configuro el navegador para usar el proxy, enseguida aparece la ventana pidiendo las credenciales. Estas son validas pues las he comprobado varias veces. Luego de poner la clave me niega el servicio si no es nacional, ademas dice, Konqueror,:
"Proxy Authentication faliled. Do you want to retry?"
Si le digo que si, Retry, vuelve a pedir las credenciales.
Si la url es de un sitio nacional entonces accede.
ya no se que hacer.
Aca les dejo mi squid.conf para ver si me pueden echar una mano.

SMB.CONF
##### Fichero de configuracion de squid 3 #####
##### Hecho por: ####################
##### Armando Victor Corona Ramos. ############

##Configuracion de Squid#
##############################################
http_port 3128

icp_port 3130

cache_peer 10.0.10.1 parent 3128 3130 default no-query
cache_swap_low 90
cache_swap_high 95

maximum_object_size 4096 KB

cache_mem 16 MB
cache_dir ufs /var/spool/squid3 100 16 256
cache_access_log /var/log/squid3/access.log
cache_log /var/log/squid3/cache.log
cache_store_log /var/log/squid3/store.log

pid_filename /var/run/squid3.pid
visible_hostname soporte

client_netmask 255.255.255.0
## Autentificacion
auth_param basic program /usr/lib/squid3/ncsa_auth /etc/squid3/control/clave

## ACL sistema
acl PURGE method PURGE
acl CONNECT method CONNECT
acl manager proto cache_object
acl password proxy_auth REQUIRED

acl all src 0.0.0.0/0.0.0.0
acl localhost src 127.0.0.1/255.255.255.255
acl redlocal src 192.168.11.0/24

acl SSL_ports port 443 563 873 5223 # https, snews, rsync, jabber
acl Safe_ports port 80 443 563 873 # HTTP, HTTPS, SNEWS, rsync
acl Safe_ports port 5222 5223 5226 5280 5269 # Jabber
acl Safe_ports port 21 # FTP
acl Safe_proxy port 3128 # PROXY
acl Safe_admin port 70 # GOPHER
acl Safe_admin port 210 # WAIS
acl Safe_admin port 280 # HTTP-MGMT
acl Safe_admin port 488 # GSS-HTTP
acl Safe_admin port 591 # FILEMAKER
acl Safe_admin port 777 # MULTILING HTTP
acl Safe_admin port 1025-65535 # Unregistered Ports

acl Usuarios proxy_auth "/etc/squid3/control/usuarios"

# Reglas por default:
http_access allow manager localhost
http_access deny manager
http_access allow PURGE localhost
http_access deny PURGE

#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#
http_access allow localhost
http_access allow redlocal password
http_access allow Usuarios
http_access deny all

haber esto esta bien acl

Imagen de falcom

haber esto esta bien

acl redlocal src 192.168.11.0/24

y luego

http_access allow redlocal password

correcto
pero esto esta mal

acl Usuarios proxy_auth "/etc/squid3/control/usuarios"

Vamos a echar un vistazo... #

Imagen de skypower

Vamos a echar un vistazo...

# Aca estan los usuarios con sus passwds

auth_param basic program /usr/lib/squid3/ncsa_auth /etc/squid3/control/clave

# Esta opcion es por si necesitas brindar accesos diferenciados, cosa que no veo que haras...

acl Usuarios proxy_auth "/etc/squid3/control/usuarios"

# Con esta basta y sobra para que se autentifiquen

acl password proxy_auth REQUIRED
acl redlocal src 192.168.11.0/24
http_access allow redlocal password

para mas info..
squid

Salud2s...

ecualug
______________________
!!!AdminRed_Debian!!!

Surge un problema.

Imagen de arvic1978

Hice el cambio que me suguieres y...
entonces squid3 no se ejecuta, parece que tiene algo que ver con la cache.
ejecuto
~~# squid3 -z
y aparece:
~~# clParseIpData: Bad host/IP: 'paco'
2009/10/07 09:40:20| storeDirWriteCleanLogs: Starting...
Violación de segmento

el fichero
/etc/squid3/control/usuarios
almacena la lista de los usuarios con derecho a usar el proxy. y tine permisos 644 propietario: proxy
en estos momentos solo tiene un usuario: "paco"
si deshago el cambio entonces todo vuelve al estado inicial.
???
??
?
Atentamente esperando ayuda

haber si te entendi en el

Imagen de falcom

haber si te entendi en el archivo "Usuarios" dices q tienes dentro el nombre "paco" si es asi, estas haciendo mal
dentro de los archivos q creaste unicamente debes tener ips... x example

192.168.0.1
192.168.0.2
192.168.0.3
...
...

haber mi pana te repito paso

Imagen de falcom

haber mi pana te repito paso a paso en tu archivo squid.conf que esta en /etc/squid
configuras tus accesos a inet e insertas estas lineas para control de users

acl Usuarios src "/etc/squid3/control/usuarios"

luego

http_access allow usuarios password

en donde el archivo usuarios debe tener las ips de cada usuario exmaple:

192.168.0.1
192.168.0.2
192.168.0.3
...
...

ojo al ultimo siempre recordar colocar

http_access deny all

esto para bloquear accesos indebidos....
haber si me entendiste.... }:)

Es posible que el problema

Imagen de Root Bit

Es posible que el problema este en la forma como estas creando tus nombres de usuarios en el archivo "usuarios" si lo estas haciendo de forma manual y estas ingresando los mismos directamente en el archivo es incorrecto.

Para la autenticacion atraves de un nombre de usuario, debes crear los mismos con httpasswd.

Revisa este enlace alli esta mas que claro el tema.

http://www.alcancelibre.org/staticpages/index.php/19-1-como-squid-autenticacion

There are only 10 types people in the world:
Those who understand binary and those who don't