apache2 y php

Imagen de skypower

Forums: 

Un colega tiene un problema y yo no he podido encontrar la solucion, esta instalado el apache2 phpmyadmin y php5 y puede abrir cualquier web html, pero si habre ej squirrelmail o phpmyadmin en vez de cargar la web le descarga un archvo con lo siguiente:

¿Que puede ser?

con squirrelmail sale esto

<?php
/**
* index.php
*
* Redirects to the login page.
*
* @copyright © 1999-2006 The SquirrelMail Project Team
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
* @version $Id: index.php,v 1.14.2.7 2006/02/03 22:27:46 jervfors Exp $
* @package squirrelmail
*/
..................................................

y con phpmyadmin


<?php
/* $Id: index.php 9718 2006-11-18 11:21:43Z lem9 $ */
// vim: expandtab sw=4 ts=4 sts=4:
/**
* forms frameset
*
* @uses libraries/common.lib.php global fnctions
* @uses libraries/relation.lib.php table relations
* @uses $GLOBALS['strNoFrames']
* @uses $GLOBALS['cfg']['QueryHistoryDB']
* @uses $GLOBALS['cfg']['Server']['user']
* @uses $GLOBALS['cfg']['DefaultTabServer'] as src for the mainframe
* @uses $GLOBALS['cfg']['DefaultTabDatabase'] as src for the mainframe
* @uses $GLOBALS['cfg']['NaviWidth'] for navi frame width
* @uses $GLOBALS['collation_connection'] from $_REQUEST (grab_globals.lib.php)
..................................................

Si me pueden apoyar, pues espero...

Y puede abrir cualquier otra

Imagen de deathUser

Y puede abrir cualquier otra página hecha en PHP, porque aparentemente no está entendiendo que se trata de una página PHP y te está botando el código sin interpretarla ...

Trata creando una página test.php y ponle algo como:


<?php
phpInfo()
?>

A ver que te sale, por cierto, que distro está usando tu amigo ...???

bye
:)

Usa Debian etch como yo, y

Imagen de skypower

Usa Debian etch como yo, y sobre el php, no le permite abrir ninguna web en php, porque cada ves que abre alguna le da guardar como... yo nunca me tope con algo como esto, porque al instalar el phpmyadmin el mismo instala el apache2, mysql-server, php5, etc... ya lo a desintalado e instalado nuevamente y nada...

ecualug
______________________
!!!AdminRed_Debian!!!

ecualug
______________________
!!!AdminRed_Debian!!!

Cuando le doy a la consola

Imagen de skypower

Cuando le doy a la consola para ver el historial de instalacion esto es lo que muestra...

Se instalo de esta manera:

apt-get install phpmyadmin mysql-server mysql-client php5 php5-gd libgd2-xpm imagemagick ffmpeg netpbm

Y cuando lo desintalamos fue por este medio

apt-get remove --purge -f apache apache2 apache-common apache2-common phpmyadmin mysql-server mysql-common mysql-client php4-common php5-common

Todo da correctamente instalado!!!

ecualug
______________________
!!!AdminRed_Debian!!!

ecualug
______________________
!!!AdminRed_Debian!!!

comentario: La primera vez

Imagen de skypower

comentario: La primera vez que instalo uso el apache y todo le iba bien, todo esto se le formo al migrar de apache al apache2... digo esto ya que puede dar alguna pista, para mi concepto es que le falta agregar algo en algun archivo la funcion de php...

ecualug
______________________
!!!AdminRed_Debian!!!

ecualug
______________________
!!!AdminRed_Debian!!!

OK, lo que tendra que hacer

Imagen de skypower

OK, lo que tendra que hacer es reistalar el S.O. completo desde 0, pero antes de eso tratare de buscar alguna solucion que estoy seguro que la hay, y la posteare aqui para aquellos que tengan por casualidad el mismo lio...

Gracias y Salud2s...

ecualug
______________________
!!!AdminRed_Debian!!!

ecualug
______________________
!!!AdminRed_Debian!!!

como te dije, la bronca

Imagen de deathUser

como te dije, la bronca (problema, lio, etc ...) parece ser entre el apache y el apache2, es probable que el php se haya instalado en el apache y no en el apache2, alguna vez me pasó al tratar de hacer convivir un apache 1.3 con un 2.x en un debian-based system, así que desinstalé, no dejé piedra sobre piedra, rastro alguno para que no pueda ser contado ... (me recuerda a una canción de demolición ... :D) del apache (1.3xxx) y ahí si instalé todo lo que requería de php en el apache2 y listo ...

Lo de CentOS era en son de broma, aunque como en el CentOS no te mezclan los paquetes no te metes en esos líos ...

Suerte ...

bye
:)

Páginas